Sign in to follow this  
ContinueTheEnd

REAPER Soundfont Issue

Recommended Posts

I'm having a frustrating problem with REAPER (I'm a new user trying to learn the ropes): I have my soundfont players (SFZ and the Font! one) both installed, and I've got two different sound libraries (one orchestral and one guitar-based) as well. My first problem is that when I assign the SFZ soundfont player to a track, IT ONLY PLAYS THE FIRST INSTRUMENT ON THE LIST. Even if I change the instrument on the SFZ player in the FX settings, when I actually hit "play", it always reverts to the first instrument on the list and ONLY plays that one...then when I open the FX options to check, sure enough, it automatically reverted to the first instrument. I'm not sure how to fix this.

My second problem is, with the Font! player, I can't hear any sound at all when I play back the instrument (although the player can load instruments and I can see it playing them "digitally", I don't hear sound!). This problem is puzzling because I can hear the playback of the SFZ player, but for some reason I can't hear sound with the Font! player.

Any advice is appreciated - thanks.

-ContinueTheEnd

Share this post


Link to post
Share on other sites

I just got Shortcircuit - however, the program can't "see" any of my sf2 files...I put a shortcut of my REAPER Plugins folder into the "sample" directory just like it said, but all I see is the folder and no samples to load in the player itself.

I'm using Windows 7 - I wonder if that messes things up. Any help is appreciated - I just need a soundfont player that works...I'm kinda disappointed that it's this hard to get one that does.

I'

Share this post


Link to post
Share on other sites
I'm having a frustrating problem with REAPER (I'm a new user trying to learn the ropes): I have my soundfont players (SFZ and the Font! one) both installed, and I've got two different sound libraries (one orchestral and one guitar-based) as well. My first problem is that when I assign the SFZ soundfont player to a track, IT ONLY PLAYS THE FIRST INSTRUMENT ON THE LIST. Even if I change the instrument on the SFZ player in the FX settings, when I actually hit "play", it always reverts to the first instrument on the list and ONLY plays that one...then when I open the FX options to check, sure enough, it automatically reverted to the first instrument. I'm not sure how to fix this.

My second problem is, with the Font! player, I can't hear any sound at all when I play back the instrument (although the player can load instruments and I can see it playing them "digitally", I don't hear sound!). This problem is puzzling because I can hear the playback of the SFZ player, but for some reason I can't hear sound with the Font! player.

Any advice is appreciated - thanks.

-ContinueTheEnd

It's been ages since I've used SFZ and don't entirely remember how it works, but it sounds like this is a MIDI channel issue. Probably the instruments on the SFZ list are each assigned to a MIDI channel (1 through 16) and which instrument plays is determined by which channel the track is sending to. Your MIDI track should have a field somewhere that says what MIDI channel it outputs on. Try changing this and see if it changes what it plays in SFZ.

Share this post


Link to post
Share on other sites
It's been ages since I've used SFZ and don't entirely remember how it works, but it sounds like this is a MIDI channel issue. Probably the instruments on the SFZ list are each assigned to a MIDI channel (1 through 16) and which instrument plays is determined by which channel the track is sending to. Your MIDI track should have a field somewhere that says what MIDI channel it outputs on. Try changing this and see if it changes what it plays in SFZ.

Thanks for the advice - I will try this.

However, you mentioned that you haven't used SFZ in a while...well, what do you use then? Is there something better that you would recommend (anything free is a plus)? Again, I am fairly new to sequencing/mixing, so any tips or advice you can offer would be appreciated.

Thanks again.

Share this post


Link to post
Share on other sites
Thanks for the advice - I will try this.

However, you mentioned that you haven't used SFZ in a while...well, what do you use then? Is there something better that you would recommend (anything free is a plus)? Again, I am fairly new to sequencing/mixing, so any tips or advice you can offer would be appreciated.

Thanks again.

It's been ages since I've used Soundfonts in general. My goto sound library right now is Vienna Symphonic SE Plus, which isn't free by a long shot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this