Jump to content

Exporting in Pattern/Song mode (FL7)


Recommended Posts

Hi, I've been running into a matter that bothers me and I hope some1 can help me solve it.

What I'm talking about is that when I export the song in song mode, it has different mixing with the effects I applied in the mixer than it has if I export a single pattern in pattern mode. In other words, pattern and song mode somehow have different mixing when I export the song. Is this normal? I wanted to make my song in more patterns, put it together on the playlist, then export the full thing in song mode, but if it keeps messing up the mixing it doesn't seem like the best idea. My goal would be to have the mixer settings in song mode that is has in pattern mode (if you know what I mean) coz that sounds better. I hope some1 can help me out here. Thx in advance.

Link to post
Share on other sites

I don't understand how this is happening, how is it messing with your mixing? Does it sound that way when you put it in song mode and press play? My best guess is that you did some tweaking as the song was playing with the record button armed, this would embed the tweaking as automation into whatever pattern you were on, but I'm really not sure.

Link to post
Share on other sites

If you've got mixer automation in other patterns, that would also account for the difference. You can use the browser to quickly see which patterns are sending what automation. I tend to label those patterns just for automation very clearly (because it's easy to get confused otherwise), or more often, use automation clips.

Link to post
Share on other sites

If you haven't seen the terms, you may not be using automation anyway. :-P It's basically automating things like volumes or amounts to change over time. You can do this within a pattern, or as a clip, which would show up in the playlist. If you were using a pattern to do this, it might set your volumes to say 100% at the beginning of the song, whereas if you just exported a pattern later in the song, it would export with whatever volumes you had set at the time.

Link to post
Share on other sites

I'm assuming since you don't know what it is, you don't have any that you want in your project, so we're going to delete anything that might cause problems. You might want to save a backup first though. Okay, open the browser (F8), now click on Current Project>Automation, if you see anything there, then that's probably your problem. If it says "Initialized controls" then go into that folder and right-click then delete everything in that folder. Now move on to any other folders in the automation folder. If there are any, they will be named after the patterns that they are recorded on, click open one of the pattern folders (if you see any) click on one of the items with a knob in front of it contained in the folder, this opens the event browser. Press Ctrl+A, then Delete to delete the entire event. Wash, rinse, repeat for all the knob icon controls in every pattern folder, then try listening to your song in song mode and see if it's better, you may need to retweak some of your settings, but at least they shouldn't change when you switch modes.

Always make sure the record button is off when you're tweaking something.

If it turns out that there's nothing in your automation directory... well then it must be something else, if that's the case is there any chance you can provide us with audio files of the change? Hope that helps.

Link to post
Share on other sites

Not if they're being automated, and no, I don't believe that deleting those loses your settings, it's complicated to explain, but that's not where the setting data is stored, make a backup and try deleting them and the automation data. The fact that you have those in that folder means that you DO have unwanted automation somewhere, and that's probably the root of your problem.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...