Sign in to follow this  
Guest

Can't record from my Yamaha PSR-310

Recommended Posts

According to your ebay link and the info from your hardware, I assume you're german? If not, gimme a hollar and I switch back to english again (sorry folks, I feel like helping in my mother-language today).

Als erstes:

Wie schließt du dein Kabel an? Am Motherboard Game Controller oder an der SB Live! und seinem Port? wenn du den Port (Mainboard) im BIOS abgestellt hast, dann kannst du dort natürlich auch nicht das Kabel anschließen.

Zweitens:

Hast du mal das Kabel überprüft? MIDI OUT am Kabel kommt beim Keyboard in MIDI IN und MIDI IN am Kabel beim Keyboard auf MIDI OUT. Ist beim Keyboard der "MIDI I/O" aktiv? (bei dem alten Gerät sollte er das)

Wenn das soweit alles stimmt, dann gehen wir mal auf die Treiber los.

Hast du eventuell unter den hardware EInstellungen nachgesehen, ob dort ein Gameport (bei der Audiokarte) existiert? Das findest du unter den Hardwareeinstellungen.

Es ist zwar schon lange her das ich eine Live! Benutzt habe, aber es müsste selbst in Windows 2000 oder XP ein extra Port erscheinen, der eine HEX Nummer um die hx380 oder ähnliches hat. Sollte dies der Fall sein, und die Treiber sind alle Installiert, dann solltest du einen MIDI Port (I/O) zur Verfügung haben (bin mir jetzt nicht mehr sicher ob der MPU betitelt wurde oder nicht). Falls nicht, schau auch gleichnoch mal nach, ob die "MIDI" Funktion unter den Treibern aktiviert ist.

Wenn all das nicht funktionieren sollte, dann musst du es noch einmal mit dem On-Board Gameport probieren. Auch hier selbiges Beispiel mit aktivieren und MIDI-Hybrid Funktion. Sollte auch das nicht funktionieren, kommst du wohl nicht an einem USB MIDI Adapter (z.B. M-Audio oder Edirol) vorbei, da kannst du dir aber sicher sein, das der geht. Denn dann kann weder dein Board, noch die Audiokarte "MIDI", oder das Adapterkabel ist kaputt. Hatte ich auch schon, deswegen bin ich auf Multi-Ports gewechselt.

Auf die Frage hin, ob dein Keyboard erkannt wird als "separate Hardware". Leider nein. Nur ger Gameport wird als "MIDI Modul" erkannt. Hast du ein separates USB Modul dafür, dann auch nur dieses. Außer du benutzt Geräte von Yamaha die M-Lan benutzen, USB MIDI Controller (Keyboards, Mixer, Adapter) oder Instrumente mit USB Ports (wie Alesis eines hat).

Sollte nun aber alles funktionieren, dann kannst du dein Keyboard aufnehmen, indem du in deinem Sequencer den passenden "MIDI IN" Port anwählst, und dann so verfährst, wie du es vom Aufnehmen deines Sequencers gewöhnt bist.

[/end german]

Share this post


Link to post
Share on other sites
Solange die Moderatoren keine Einwände haben, können wir das gerne auf Deutsch klären. :)

Wird zwar ein wenig gemault, und jokes gemacht, ist aber nicht weiter wild.

Ich habe es zuerst am SB Live!-Port angeschlossen. Da es da nicht ging, habe ich den Motherboard-Port im Bios deaktiviert, was aber auch nichts gebracht hat. Dann habe ich den Motherboard-Port wieder aktiviert und es da reingesteckt, keine Änderung.

Manche Motherboards haben zwar den Gameport, der gute alten MIDI Port wurde aber immer mehr vergessen und schlicht und einfach entfernt. USB bietete einfach viel mehr Möglichkeiten.

Ich habe schon alle möglichen Konstellationen ausprobiert, weil ich mir auch nicht ganz sicher war, wo denn die Kabel jetzt reinkommen. Aber nichts hat geholfen. Die zweite Frage verstehe ich leider nicht ganz.

Hm... dann kann es sein, das wie gesagt entweder das Kabel kaputt ist, oder das der GamePort kein MIDI mehr unterstützt. In dem Fall ist es dann ganz schlecht.

Mit der anderen Frage meinte ich eher ob man am Keyboard "MIDI IN/OUT" (kurz I/O) einstellen kann. Nachdem das PSR-310 aber recht alt ist, denke ich das dies standardmäßig aktiv ist. Manche Keyboards kannst du einstellen, oder Ports filtern. Z.B. wenn du Geräte in Reihe schaltest (MIDI Thru, sogenannte MIDI Chains). Denke aber da brauchst du dir keine Sorgen machen.

Hier sind meine Hardware-Komponenten, die Dinge, die du meinst, habe ich rot markiert. Der MPU-Port ist also vorhanden.

Also sollte zumindest die Ansteuerung intern funktionieren.

Mit Aktivieren meinst du jetzt im BIOS, oder? Und MIDI-Hybrid-Funktion müsstest du mir nochmal erklären.

MIDI-Hybrid meine ich die Ports selbst. Im Grunde genommen sind diese ja in erster Linie "Game Ports", keine MIDI Ports. Das Signal wird aber parallel gesendet. Damals war das immer recht witzig wenn du z.B. ein Spiel spielst und abwechselnd MIDI benutzt. Irgendwann mochte das dann nicht mehr richtig. Oder aber wenn du eine Wavetable Karte (Yamaha hat da z.B. welche) eingebaut hattest, dann ging der Gameport nicht mehr, weil dieser der Wavetable zugeschrieben war.

*sigh* Die Guten alten Zeiten, heh. Nun gut... der Port läuft also parallel. Schau einfach mal nach ob es unter den Hardware Einstellungen nicht irgendwo einen Haken zu setzen gibt, der den MIDI aktiviert. Wie gesagt, ist für mich schon zu lange her, da ich längst auf USB und Terratec Karten umgestiegen bin.

Der MPU ist ein alter MIDI Port (beim PC kann man das als "Zusatz Modul" ansehen, das den Gameport quasi für MIDI freischaltet). In unseren Fall wird er also durch das Mainboard geschliffen. Zumindest sollte er das laut Treiber. Also dürfte dieser Port auf jeden Fall funktionieren. Warum er das aber doch nicht tut, kann viele Dinge haben. Und ob du es glaubst oder nicht, die sind banal!

Da wäre das Kabel. Du glaubst ja nicht wie viele MIDI Adapter Kabel ich schon tauschen musste bis mal eines funktioniert hat.

dann der Port: Der Treiber kann zwar existieren, es heißt aber nicht das die Karte, bzw. das Mainboard dann auch funktioniert.

Und natürlich das Keyboard: Der MIDI Port ist entweder deaktiviert, defekt, oder gar nicht vorhanden (letzteres trifft in deinem Fall nicht zu, außer die Ports sind nur dummies, was ich nicht glaube).

Es gibt für dich jetzt also nur die möglichkeit noch mal mit den Ports zu experimentieren, ein neues Kabel zu organisieren. Oder aber du machst es dir einfach. Geh zu einem Musikladen deines vertrauens, nimm dein Keyboard mit und teste an einem USB Modul ob das Keyboard auch wirklich geht. Wenn es dann funktionieren sollte, bleibt dir nur noch die USB Lösung.

Die empfehle ich aber mittlerweile jeden (vor allen Einsteigern), man kann so gut wie nichts falsch machen, sie laufen fehlerfrei, die Anschlüsse sind meist 5pin Buchsen (man braucht nur noch normale MIDI Kabel) und du hast nicht das Problem deine "Gameports" zum laufen zu bringen - kurz: sie sind komfortabel. Damals war das wirklich noch die einzige Lösung, aber mittlerweile sind USB Adapter so günstig, das man sich den Streß mit MIDI Adapterkabeln und Gameports einfach nicht mehr gibt.

Hoffe ich konnte helfen, auch wenn's keine Hiobs-Botschaft für dich war. ;)

Share this post


Link to post
Share on other sites

Denke ja, das wäre dann deine Alternative. Günstige Teile gibts von M-Audio (die haben MIDISport aufgekauft) und Edirol. Normale 1x1 bzw. 2x2 Module sollten es tun.

Schau dich einfach mal bei thomann.de oder so um. Die haben garantiert was.

Share this post


Link to post
Share on other sites

More liek Fräulein Bürgermeister, if you call your cat like that.

*cough*

Ich bin neugierig, Prime. Was hast du gemacht das es nun doch läuft? Treiber gelöscht (und von Windows automatisch neu installieren lassen), bzw. ein Gameport komplett deakitviert (man kann ja nie wissen)? Noch mal die Routings gecheckt? Oder gings von selbst?

Nur der Vollständigkeit halber.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this