Jump to content

Windows XP Died!


Recommended Posts

I just came home from college. Brought my computer. It was working perfectly fine about an hour before packing up for home. The computer rode home with me in the front of the car, as it didn't fit anywhere else.

When I got it all plugged up at home, it gave me an error: "ntldr is missing" assumedly after running the POST.

I tried using the solution [link=http://www.computerhope.com/issues/ch000465.htm]here[/link] under "Windows XP users" involving copying the broken files from the Windows XP CD. (With changes to my appropriate drive letters, of course.)

My computer is formatted into three partitions. An empty c:\ drive, Windows XP on the d:\ drive, extra data on the e:\ drive, and the CD on the f:\ drive.

After running that copy fix... my computer no longer recognizes my d:\ as a windows drive, and thus cannot boot up. I would simply install a second Windows copy onto the empty drive, and try to fix things from there, but the paper I have with the windows XP key is missing, and I had the information archived in my Gmail account, but Gmail decided to mysteriously delete all by my few most recent letters in my inbox.

I need to know a fix for how to get my computer to recognize d:\ as a windows boot drive again, or I need to find a way to recover my CD key from that partition.

Also. My computer uses an SATA hard drive, and none of the other computers in this household have SATA compatable motherboards. However, I -would- be able to rip a hard drive out of one of the other computers, and probably set it up as the primary hard drive in my computer, boot in safe mode Windows from that hard drive, if I needed to do that as part of the fix.

Link to comment
Share on other sites

After looking through everything a little better...

It seems my boot.ini file is COMPLETELY MISSING.

I can't locate it in the c:\ root directory (Somehow my Windows partition has moved itself back to c:\) with a dir command. Trying to do an "attrib -h c:\\boot.ini" or a "attrib -h boot.ini" while in the c:\> prompt tells me it can't find the file.

Trying to run a "bootcfg /rebuild" command--gives me an error within the console about being unable to complete the command or something, after the options portion of the first time I attempt to use the command. It gives me a buffer overrun BSOD after the second attempt.

That Linux CD didn't work. I put it in, it gives me a pretty boot menu. Either doing "Live CD" from the options, or "Safe Boot" gives me a long list of loading up with [ok] messages I'm familiar with from working with Novel's operating system... but after those all scroll by, I'm left with a black, blank screen, and a solitary mouse cursor floating in the Void that is made of my monitor's display.

I'm getting closer, I think. Giving the bootcfg /rebuild command a few more tries, and if it continues to frustrate me, I may try to plug in another hard drive with Windows XP already on it, set it as the primary hard drive, and manually insert a boot.ini file onto the root of the first drive's file system.


The bootcfg /rebuild command works as following for me -- It says I have one operating system installed, on my C:\ drive. All well and good. It asks me if I want to add that to my boot list. I enter yes (or "y" in this case). It prompts for the boot identifier. I enter "Microsoft Windows XP Professional". It prompts for options. After reading through various websites, I've come to believe I should enter "/fastdetect /noexecute=optin" there, as I have an AMD 64 bit processor [apparently with nx Buffer Overrun Protection]. Either that, or simply "/fastdetect" or "/noexecute=optin" or "exit" give me the same error message: "Failed to add specified boot entry to the directory list" Sometimes it gives me this error directly after the boot identifier prompt. And occasionally it gives me the Buffer Overrun BSOD instead of the "Failed to add..."

I'm stumped, tired, angry, confused, and a slew of other unhappy emotions. I'm going to bed now, and I hope to find some answers tomorrow. If anyone can direct me to a better (working) Linux CD download site, I may try that again, and either manually copy over a boot.ini file that I think may work, or just grab my XP key through Linux, and reinstall the whole mess. Provided Linux will install for me.

Link to comment
Share on other sites

If anyone can direct me to a better (working) Linux CD download site, I may try that again, and either manually copy over a boot.ini file that I think may work, or just grab my XP key through Linux, and reinstall the whole mess. Provided Linux will install for me.



It may be a little big for what you need, but it has always worked for me.

Link to comment
Share on other sites

That Ubuntu Linux worked... but only under a safe-boot mode. :/

Anyway, I did manage to retrieve and backup my important files onto another hard drive, which I am now in the process of writing onto a CD for safer keeping.

However, I was unable to retrieve my Windows CD key from the NTuser.dat file by the method I was trying to. (It gave me something that looked like a CD Key, but I didn't recognize it as the one I've entered multiple times [i've memorized at least the first 5 characters] and when I tried to enter the key upon installing Windows onto the blank partition, it said it was invalid.)

I need to find a method for retrieving that CD key now. I don't want to have to pay $100+ for a new copy of Windows XP Professional, or whatever operating system, and I'm pretty certain my family won't be able to use Linux while I'm away.

This problem's getting old, fast. I'm feeling stupid here, beaten, and grumbling about it the whole time.

Anyway, I now need some way to retrieve my Windows Pro CD key. I -do- have access to all my files now, and am able to run Ubuntu Linux on my computer, as well as having a way to transfer files over to and from a Windows XP Home machine. I've tried searching Google for a way to retrieve the key, but haven't found a successful way yet, and because of the busy schedule I have right now, I'm not able to do a lot of digging. Any extra help anyone has would be greatly appreciated.

*runs to curse at his computer before heading to sleep once again*

Link to comment
Share on other sites

The Key should be in the registry and you should be able to get access to it with the live cd. Don't quote me on this one but I think the registry entry is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProductId


....I need a little more sleep today, that there is the ProductID which is generated from the CD-Key. But I am sure that there is a way to either get the CD-Key out of the registry or get the CD-Key out of the productID, have a look on the MSKB for more info.

Link to comment
Share on other sites

Success! (I hope...)

I realized just about an hour ago that I had a virtual hard drive stored on my machine, with the same Windows Professional CD Key installation. I booted up Ubuntu Linux off the CD I made (I'm liking that thing more and more all the time now) and grabbed that .vhd file. Then I stored it onto the machine I'm using right now (My brother's) and installed Virtual PC onto my brother's machine. I ran my virtual disk off of that, and was able to use a CD Key retrieval program (Only works while you're in the Windows you're getting the CD Key from -- seems almost useless in most application, but it worked for me).

Apparently the CD key that didn't work before, that I thought I'd gotten was actually my -brother's- CD Key. He uses Windows Home Edition.

Anyway, I've deleted both of the 20GB system partitions off of my own computer, leaving just the 200GB Data partition. I'm reinstalling Windows XP Pro on the now blank 40GB partition. And now that I have a working CD Key (I recognized this one as definitely mine) I hope that everything will work out just fine -- barring any problems with the PHYSICAL portions of the hard drive itself. Or any nasty lingering things somewhere on it, such as weird stuff in the Data partition -- which I doubt is likely at this point.

Update in half an hour, to an hour, once Windows is done installing. And... the CD key entering portion just came up, and the key worked successfully!

Edit: Yes, it's working perfectly now. I'm using the computer in question right now, to post. Things look great!

Also, as a curious note: My Windows install ended up on the D: drive. Data is on the F: drive, and there's a strange little 9MB partition for C: to store those important system-wide files.

A note to be learned from all of this: No matter what partition system you have, and no matter what drive letters your windows installations are on, your C: drive is very, very important, if you use windows installations.

Link to comment
Share on other sites


Bleh, just when I had it working again...

I installed the drivers for my motherboard, my video card, and my mouse. I then reset the computer, and it continued to work fine.

I let it sit overnight, while it apparently downloaded and installed the automatic Windows updates.

I came back the next morning to find it frozen at the boot splash screen (The one with the 'press del to enter setup')

I held the power button to turn the computer off. Pressing the button quickly did nothing.

Turned the computer back on. It was still frozen.

Freezes at the 'press del to enter setup' screen. I can't even press del and have it respond.

I think my motherboard might have given out on me. ASUS A8N5X

Removed the CMOS battery, disconnected the hard drive, CD drive, network cord, power cord, USB keyboard and mouse.

I let it sit for a little while, and then plugged back in the power cord, CMOS battery, and a PS/2 Keyboard. Turned on the computer.

It's working now, kind of, but it keeps shutting off about ten seconds after entering Windows.

Link to comment
Share on other sites

I stand corrected.

If I remove all cords from the computer's outside (but nothing from inside) and remove the CMOS battery for a while, and then plug just the keyboard, monitor, power, and CMOS back in, everything will work fine, and I can connect everything else after I'm in windows.

It may be taking a few steps more than I need, but I know if I just leave everything connected and turn off the computer, then turn it back on, it freezes at the 'press del to enter setup' screen until I do all of the above.

I'm pretty sure my motherboard's giving out on me. *sigh*

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.


×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...