Jump to content

Don't let the Giga Continuous Velocity Piano get away


Recommended Posts

Garritan has bought TASCAM's Giga line. They have not yet announced what they're going to do with the software, but the buyout means that the Giga Continuous Velocity Piano that TASCAM is giving away could disappear without advance notice sometime in the coming months. I hate to sound like an alarmist, but it's the best free piano VST that I know of, so if you don't have it, get it, and make a backup.
Link to comment
Share on other sites

I downloaded it but when I try to install its all "You must have windows xp service pack 2 or better to install this" and I have service pack 3 :S I dont get whats wrong

This right here is one reason why Tascam eats wheelbarrows full of balls and must sell their stuff to garritan

Hey tascam, god forbid we update things

unlike you

Link to comment
Share on other sites

To be honest, I've never really been a fan of this, it has weird key release noises which, while realistic are really annoying.
Bah! Thou shalt not speak against my favorite piano plugin.

To disable key damper noises:

1) From the midi mixer page, click the green edit button. This should take you to a page with 3 horizontal yellow bars. The lower left one represents the damper release sample trigger.

2) By default the sample is set to play when you release a key (as in a real piano). That's what the "RelTrig" stands for. Click on "RelTrig" and change it to some midi controller that you don't plan on using (say, (80) Gen. Purpose).

3) Now the horizontal bar should have a numerical value (between 0 and 127) displayed somewhere along it. Click the number and drag it left to zero.

To disable pedal damper noises:

1) By default the pedal samples are mapped to the D7 and D#7 keys and are triggered at random. Towards the bottom of the edit screen, set the "kbd select" mode to "individual regions"

2) Click on the tiny white (or yellow) rectangle just above the D7 key on the keyboard. If it wasn't yellow already, it should turn yellow to indicate you've selected it.

3) There are a number of ways to eliminate the sound, but the easiest is probably just to turn the volume down. With the D7 key selected, lower the volume knob towards the upper left of the screen to -inf. Repeat for the D#7 key.

Voila! No damper noises.

"You must have windows xp service pack 2 or better to install this" and I have service pack 3
Hmm, that sucks. Works for me in sp3, but I installed it when I had sp2. Guess the programmers got lazy when writing the install program compatibility checks :/
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...