Sign in to follow this  
starla

FRUITY LOOPS 101 - PLEASE direct -ALL- FL questions here

Recommended Posts

Blimey, three questions in a row... well, starting at the top:

@TSN: Make sure your audio is all set up properly. Go to Options > Audio Settings, and make sure you have the rigth sound device selected. If that doesn't work... uhhhhhh... Make sure your speakers are plugged in?

@XOR - SYS: Yeah, this is crazy buisness. The same thing happens to me. I managed to fix it once, but that was at 4am, and I can't remember how I did it. Anyone else know how to fix it?

@myka316: It sounds like you aren't using the piano roll. Right click on the channel (in this case GloomPrelude) and go "piano roll". The keyboard on the left tells you which note is which, and is also a handy-dandy testing keyboard. Its fairly easy to figure out, so I won't bother going into all the fuctions of the piano roll - though the help file is great place to read up on it.

Share this post


Link to post
Share on other sites

Also at myka316: That's a .wav sample. However, this .wav sample thankfully has a [good] loop point. When you encounter something with a loop point [should be 2 red bars in the waveform], in the channel properties go to "use loop points."

Share this post


Link to post
Share on other sites

@TSN: Make sure your audio is all set up properly. Go to Options > Audio Settings, and make sure you have the rigth sound device selected. If that doesn't work... uhhhhhh... Make sure your speakers are plugged in?

I tried everything. Nothing works. And yes, my speakers are plugged in. I give it MIDI files, and they wont read them! It's still confusing. :cry:

Share this post


Link to post
Share on other sites

I have a (hopefully) simple question. So there's the echo/delay settings under the misc functions and tools tab when you open any sample or loop or soundfont or anything. my question is, is there a way to make the delay 'stick' to the tempo? i know i can just stick the 'time' knob at 2 or 3 or something, but say i wanted to make some live automations, and i just wanted them to automatically jump to 2 or 3 or 4 instead of all the ones in between...is there a way to do this? hmm... sorry if this is a uber noob question :-P

Share this post


Link to post
Share on other sites
just wanted them to automatically jump to 2 or 3 or 4

This took me a while to figure out but I finally got it. When using the Event Editor, mouse over the editing field. FL'll give you a percentile or number [sometimes even a name or On/Off] in the line on the main toolbar at the top of the screen, so you get a more accurate value instead of an estimate.

Share this post


Link to post
Share on other sites
When using the Event Editor, mouse over the editing field. FL'll give you a percentile or number

damn really? so i can't do this, say, if i were recording stuff live? like i have a midi controller and whatnot...basically i would have to edit the events after i recorded stuff? bleh...oh well, if that's the only way ill just do it :)

thanks a bunch man :D

Share this post


Link to post
Share on other sites
There's a video tutorial here if you're a registered user.

I'm not, do you know of any sites that give away this kind of information for free?

I bought FL Studios from a store (as opposed to the internet), and I don't think I have the option to see them either. How lame. :P

Share this post


Link to post
Share on other sites
There's a video tutorial here if you're a registered user.

I'm not, do you know of any sites that give away this kind of information for free?

I bought FL Studios from a store (as opposed to the internet), and I don't think I have the option to see them either. How lame. :P

You have to register, but I'm almost positive that you're able to view the tutorials.

And, XOR-SYS, I've been playing more with automation clips, and I think I've got a grasp on them, but I'm a little confused by your question. Are you saying that when you make an automation clip, you want to be able to have unique clips controlling the same function? You simply need to create a new automation clip linked to the same function.

For example, say you'd like to put both a fade in and a fade out on the volume of an instrument. You simply right click on the volume knob to make an automation clip for fading in on one line, and then right click again on the same function to make a new automation clip for fading out on the second line.

Like so:

autoclips.jpg

Is that what you were asking?

Share this post


Link to post
Share on other sites

I've got a question, I use FL Studio and Reason, and I rewire Reason thru FL Studio. Now, whenever I make a tempo change in FL, the audio being rewired from Reason momentarily mutes if I'm slowing the tempo, or jumps ahead if I make it faster. Any help?

Share this post


Link to post
Share on other sites

Hey guys, I'm new to Fruity Loops and have been messing around with it and doing tutorials for about the past week. I've managed to get a pretty decent understanding of how to use the program but need help with Soundfonts.

Now, I'm sorry if this question has been answered previously in this thread, but 150 pages is a bit too much to search through.

So, my question is:

Once I download a Soundfont, how do I use it in Fruity Loops? Thanks a lot.

Share this post


Link to post
Share on other sites
Hey guys, I'm new to Fruity Loops and have been messing around with it and doing tutorials for about the past week. I've managed to get a pretty decent understanding of how to use the program but need help with Soundfonts.

Now, I'm sorry if this question has been answered previously in this thread, but 150 pages is a bit too much to search through.

So, my question is:

Once I download a Soundfont, how do I use it in Fruity Loops? Thanks a lot.

Well, the Fruity soundfont player only plays .sf2 files. Or at least, thats all I am aware of it playing. Smeh. Anyways, get your soundfonts into the .sf2 format - usually you have to extract them out of some crazy format - I know Darkesword's ones (which are sexy good 'fonts, btw) are in some crazy format. He hosts a decompression tool though, so that shouldn't be an issue.

So, you have your soundfonts in .sf2 format. Now, load up fruity, and load up your soundfont player. Do this by going channels > add one > Fruity Soundfont player. If you aren't using the Fruity soundfont player then go channerls > add one> More... and then choose your soundfont player.

Then, bang out a few notes and you are away!

Share this post


Link to post
Share on other sites

Aggghhh...

I'm trying to export something into MIDI, but it always turns out to just be a bunch of piano notes. When I import it back in, it looks different and I can't hear a thing. Am I doing something wrong? Lol...

Share this post


Link to post
Share on other sites

Ok, I have a question, I didn't see it anywhere, but I didn't check every page of the thread either. My question is this, I just got fruity Loops, and I was going to open a midi within the program. Now, I did what this site told me, set the port to 0 and the remote stuff and how that should be set. However, I am finding that when I open the midi's in Fruity Loops, they are *wicked* soft, like, I have to squeeze my headphones into my ears to hear them. How do I make them louder, if that is possible. I checked in volume control under the "midi" area, and it is maxxed as well. Thanks.

Share this post


Link to post
Share on other sites

Ok... I'm going to try to answer both at once, because the questions are related. Anyways, here we go:

MIDI is just a bunch of notes. NOT SOUNDS. What a program does when it plays a MIDI file is pass the notes onto your soundcard and then the sound card produces the sound. Thus, a midi file will sound different on a different sound card.

So what fruity is doing with one of its midiout channels is routing data to your soundcard (or whatever you want - that is what you setup in the remote section of options), and then the soundcard actually does the sound production, not fruity.

Hence, Zaphoy, I would speculate that your soundcards midi volume is set rather low. Look through the windows volume controls, hopefully something will be there. Alternativly, you could just copy the midi notes into a different channel. You will probably get a better sound this way too.

Lemon of Hyrule, I would recomend you do the same thing - copy the notes into a different channel. The reason it turns out to be "just a bunch of piano notes" is because that is all it is. Just plug the notes into something that can make some noise, and you're away.

Hope that helps.

Share this post


Link to post
Share on other sites

Hence, Zaphoy, I would speculate that your soundcards midi volume is set rather low. Look through the windows volume controls, hopefully something will be there. Alternativly, you could just copy the midi notes into a different channel. You will probably get a better sound this way too.

My Volume control is maxxed already. I think I said that. However, how do I copy the notes into a diffrent channel?

Share this post


Link to post
Share on other sites

Currently the notes are in a piano roll on a MIDIout channel right? Well then, to copy the notes, simply right click on the channel, go edit>copy, and then right click on the destination channel, and go edit>paste. That should do it. Oh, to add another channel, go channels>add one.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this