PDA

View Full Version : Kontakt 2 -> Kontakt 4, Cubase SL3 -> Cubase 5. Are these upgrades worth it?


DZComposer
10-06-2009, 05:21 PM
I've been mulling over upgrading to Kontakt 4 and Cubase 5. I currently use Kontakt 2 and Cubase SL3.

I am just wondering if any of you have upgraded an whether or not you feel it was worth it. These are my primary tools, so I want to get some opinions before dropping the cash.

big giant circles
10-06-2009, 05:28 PM
Well, I'm not a Cubase user, but if I were, I would probably say that it'd be worth it just because of the upgrade to 64-bit, not to mention the new stuff like pitch correction.

Kontakt 3 probably wasn't a huge upgrade until 3.5 came out, which introduced 64-bit as well as a HUGE performance boost in streaming so that loading times are faster and waaaay less RAM is used. However, Kontakt 4 is out now, and it's not only got a better core library, but also the new attributes-based browser which looks AWESOME. Zzounds should be shipping mine out today and I can't wait to use it.

I'd say if you can afford both, the upgrades should be worth it.

Remember to use this zzounds affiliate link (http://www.zzounds.com/a--925434) if you plan on going through with this. They'll match the lowest price + free shipping and no tax (unless you're in NJ).

Skummel Maske
10-06-2009, 05:36 PM
I believe the Cubase upgrade would be worth it, Cubase 5 has some pretty nifty new features since version 3. I made the jump two weeks ago myself, and I don't regret it.

One note about running Cubase in 64-bit though: Most 32-bit VSTi's won't work anymore. After reading their forums I've realized that their "bridge" isn't very reliable. I use several small and old VSTi's myself, so I ended up going down to the 32-bit installation.

big giant circles
10-06-2009, 06:00 PM
Well, jBridge (http://jstuff.wordpress.com/jbridge/) should address that issue I believe.

DZComposer
10-06-2009, 07:42 PM
Well, I'm running a 32-bit OS (WinXP) right now, so I do not think 64-bit will help me at the moment.

Though I've been thinking about picking up Windows 7 64-bit when it comes out in a couple of weeks, but I would like to know about compatibility issues first.

I'm skipping Windows ME2ImeanVista

Maybe I searched wrong, but I was unable to find the Cubase Upgrade versions at zzsounds... I love OCR, but not enough to buy full price version when I am upgrade price eligible.

Yoozer
10-06-2009, 08:04 PM
Like mentioned, why upgrade to 3 when 4 is out? Also, Akoustik Piano and Elektrik Piano are now included in the library.

big giant circles
10-06-2009, 09:03 PM
Where did you read that about Akoustik Piano?

Not like it matters to me since I've already got it, but I didn't see that on NI's site, only Elektrik.

Meteo Xavier
10-07-2009, 02:07 AM
Akoustic Piano and Elektrik something or other is on 4 too?

That would be sincerely useful for me since I have struggled with decent piano samples since the beginning.

DZComposer
10-07-2009, 01:03 PM
Like mentioned, why upgrade to 3 when 4 is out? Also, Akoustik Piano and Elektrik Piano are now included in the library.

Because I somehow missed that Kontakt was now at version 4....

Now that I know this, that will be my target version.

Yoozer
10-09-2009, 12:22 PM
Where did you read that about Akoustik Piano?

Argh. I mailed them, got a reply a few days later (they must've been swamped), and I thought Akoustik was included; but only Elektrik was confirmed.

I told 'm I wanted to see the Scarbee Rhodes released as Kore pack. I hope that's going to happen...