djpretzel

NOTICE: Forums upgraded to IPS 4.1.X (report issues)

112 posts in this topic

I know I asked a week or so ago, but I don't recall seeing a reply.

I've seen others talking about how their post count dropped quite a bit, with myself going from 23,300-plus, to 5,300-plus. Which begs the question, what happened?

Share this post


Link to post
Share on other sites
9 hours ago, The Coop said:

I know I asked a week or so ago, but I don't recall seeing a reply.

I've seen others talking about how their post count dropped quite a bit, with myself going from 23,300-plus, to 5,300-plus. Which begs the question, what happened?

select count(*) from forums_posts where author_id = 935

This returns 5332, which is one off... I'm guessing that the 23K number was potentially based on posts contributed to myriad off-topic and older threads that were pruned back in the vBulletin days. vBulletin would have kept the count intact post-pruning, but IPS seems to have rebuilt it... at least, that's a potential explanation. Odd then that it didn't rebuild back when we originally converted to IPB 3.4.7, and instead the reset seems to have been triggered by IPS4...

At least, that's the best I can come up with... your current content count DOES match up with what's still in the database, i.e. on the site... it's hard to imagine that 18K posts of yours have been pruned over the years, but if they were plentiful and in some of the threads that have gone bye-bye... does it sound plausible/possible?

Share this post


Link to post
Share on other sites
On 12/15/2015 at 11:13 AM, MindWanderer said:

I'm not sure if I'm repeatedly being an idiot, but every time I schedule a calendar event to begin or end at noon, it ends up getting changed to midnight the following morning.  The first couple of times I figured I'd made a mistake, but now I'm trying to be very careful about it and it keeps happening.  For instance, CCoI signups are supposed to end January 6 at 12:00 PM, but the event now shows January 7 at 12:00 AM.  I put in a correction (and yay, edits no longer delete the whole event), but it didn't change, although I suppose the change might not have been approved yet (though I put it in yesterday, and usually someone approves it within a few hours).

 

On 12/16/2015 at 11:18 AM, MindWanderer said:

Addendum: I thought I put in a correction.  Apparently it failed because I omitted a "required" field.  This is a problem in two ways.

  1. You can't tell that it failed right away--you have to scroll down the page looking for the red text that wasn't there before.
  2. "Calendar" is a required field.  However, when editing an existing event, it defaults to "Select" (i.e. no calendar chosen) and is also disabled.  This makes edits impossible.

Still hoping for an update on this.  I don't want people submitting their source selections 12 hours after the deadline by accident... although I suppose I'd just change the deadline to match the calendar in that case.

Share this post


Link to post
Share on other sites
5 hours ago, djpretzel said:

select count(*) from forums_posts where author_id = 935

This returns 5332, which is one off... I'm guessing that the 23K number was potentially based on posts contributed to myriad off-topic and older threads that were pruned back in the vBulletin days. vBulletin would have kept the count intact post-pruning, but IPS seems to have rebuilt it... at least, that's a potential explanation. Odd then that it didn't rebuild back when we originally converted to IPB 3.4.7, and instead the reset seems to have been triggered by IPS4...

At least, that's the best I can come up with... your current content count DOES match up with what's still in the database, i.e. on the site... it's hard to imagine that 18K posts of yours have been pruned over the years, but if they were plentiful and in some of the threads that have gone bye-bye... does it sound plausible/possible?

Plausible, sure. It's still a bummer, though.

Share this post


Link to post
Share on other sites
1 hour ago, Slimy said:

Oh no, everyone's ID changed? That means I've submitted remixes with the wrong ID in the email.

 

38 minutes ago, Anorax said:

That^ could be a problem, especially if people have memorized their old IDs.

Don't worry, we use that for reference only and will catch any issues... furthermore, the IDs changed back when we moved to IPB, not with this recent upgrade.

Either way, not an issue/concern now, and even less of an issue once we automate the submission process - which WILL happen in 2016, or someone gets to punch me in the face...

Share this post


Link to post
Share on other sites
1 hour ago, djpretzel said:

Either way, not an issue/concern now, and even less of an issue once we automate the submission process - which WILL happen in 2016, or someone gets to punch me in the face...

I just didn't notice it in the last version because........... well, I really like this version of the forum software, and dug into what it offers a bit more ;) The last one for whatever reason just seemed too confusing. 

As for who can do the punching, I nominate this guy

x9J5FRR.gif

Share this post


Link to post
Share on other sites
On 12/28/2015 at 0:16 PM, MindWanderer said:

Still hoping for an update on this.  I don't want people submitting their source selections 12 hours after the deadline by accident... although I suppose I'd just change the deadline to match the calendar in that case.

I think I figure out why I can't set the Calendar field now.  It seems my event-creating privileges have been revoked--I can't find a "create event" button anywhere anymore.  I can't select either calendar because I can't create events in either calendar.

Share this post


Link to post
Share on other sites
On 12/31/2015 at 2:30 PM, MindWanderer said:

I think I figure out why I can't set the Calendar field now.  It seems my event-creating privileges have been revoked--I can't find a "create event" button anywhere anymore.  I can't select either calendar because I can't create events in either calendar.

Yeah we have to look at events again. Permissions might've been mucked in the upgrade.

Share this post


Link to post
Share on other sites

Internal server error whenever I try to post... on phone and website.. not sure what causes it. The only thing I can think of that is consistent whenever I fail to post a post is including an emote, but I wasn't able to replicate that..

As a side note it was doing the same thing when I tried to send a message on my phone.

I'm sorry I don't have more info but I really don't know what causes it, whether it's a certain character, an emote, or something else. 

Edited by Brandon Strader

Share this post


Link to post
Share on other sites

The "see who voted for this" poll feature doesn't work.  It seems to load for half a second, then just collapses.  Tried a couple of browsers.  Oddly, inspecting the HTML, the popup seems to be loading a bunch of elements that normally belong in the HTML head (title, meta, and link tags).

 

Oh, that's interesting.  Didn't realize pasting internal URL's would do that.

Share this post


Link to post
Share on other sites
21 hours ago, MindWanderer said:

The "see who voted for this" poll feature doesn't work.  It seems to load for half a second, then just collapses.  Tried a couple of browsers.

@MindWanderer Confirmed as an actual bug in IPS 4.1.7.

They've released a patch, but they've also announced it'll be fixed in 4.1.8, so I think I might just wait to get the official fix as part of that upgrade, which should drop in a couple weeks.

Share this post


Link to post
Share on other sites
On 1/28/2016 at 5:13 PM, djpretzel said:

@MindWanderer Confirmed as an actual bug in IPS 4.1.7.

They've released a patch, but they've also announced it'll be fixed in 4.1.8, so I think I might just wait to get the official fix as part of that upgrade, which should drop in a couple weeks.

Well, we've upgraded to 4.1.8, and the issue *appears* to be resolved. @MindWanderer, please let me know if you see it happen again!

Share this post


Link to post
Share on other sites
44 minutes ago, djpretzel said:

Well, we've upgraded to 4.1.8, and the issue *appears* to be resolved. @MindWanderer, please let me know if you see it happen again!

Figures, right after I post the new voting thread.  Thanks, though.

Here's an oddity: I have the ability to not only delete threads I created (makes sense), but to hide them as well.  But I can't see hidden threads, even ones I created, even if I go straight to its URL.  I can't think of a good reason why it should be set up this way.

Share this post


Link to post
Share on other sites

My latest Notification says Stahalamora commented on the Mascot Bio thread, but she was in fact Following it. Clicking said Notification led me to the last post she made (in a different thread). Weird.

Share this post


Link to post
Share on other sites
1 hour ago, Polo said:

My latest Notification says Stahalamora commented on the Mascot Bio thread, but she was in fact Following it. Clicking said Notification led me to the last post she made (in a different thread). Weird.

I moved that post to a different thread because it had nothing to do with the mascot project.

Share this post


Link to post
Share on other sites

Almost every time I leave a forum tab open and I get a notification, I see a weird character pop up on the title where it should say ([number of notifications]) - this is on Firefox on Windows 10, and Chrome on OS X.

Share this post


Link to post
Share on other sites

I don't think I see tags anymore for remixes....did those disappear? Or have they been removed for some reason? I thought it was a really handy way of finding similar mixes.

Share this post


Link to post
Share on other sites
1 hour ago, WesternZypher said:

I don't think I see tags anymore for remixes....did those disappear? Or have they been removed for some reason? I thought it was a really handy way of finding similar mixes.

We do those in the actual site database now, which isn't visible to users yet. It's a work in progress. :-)

Share this post


Link to post
Share on other sites
5 hours ago, djpretzel said:

We just upgraded to 4.1.9 - please let us know if you experience any issues!

The calendar events seem to have dropped off the front page.  At least, the CCoI voting events did--not sure if that's because they've already started and are ongoing now, or because they're in the competitions calendar, or what.  But previously they showed during the event.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now